Is WordPress compatible with MySQL

WordPress.org

For the operation of WordPress we recommend that your web hosting supports the following:

  • PHP version 7.4 or higher.
  • MySQL version 5.6 or higher ORMariaDB version 10.1 or higher.
  • HTTPS support

That is actually all. The WordPress development team recommends Apache or Nginx as the most robust and powerful servers to run WordPress, but any server with support for PHP and MySQL will do. Still, not every possible environment can be tested, and each of the hosts on the WordPress.org hosting site will support the above and more with no problem.

You can find detailed recommendations on PHP extensions in the hosting manual.

Note: If you are in an outdated environment with older versions of PHP or MySQL, WordPress will also work with PHP 5.6.20+ and MySQL 5.0+, but these versions are no longer maintained and can represent potential security risks for your website.

Ask about it

Here is a letter that you can send to your provider - just copy and paste!

I am planning to use the open source software WordPress and am wondering whether my contract meets the following conditions:

  • PHP 7.4 or higher
  • MySQL 5.6 or higher OR MariaDB 10.1 or higher
  • Nginx or Apache with the mod_rewrite module
  • HTTPS support

Many Thanks!

Not required, but recommended for better security

Hosting is more secure when PHP applications like WordPress run in the context of your account username instead of your server's default username. Ask your potential host what measures are being taken to keep your account safe.